[PATCH] D65698: [GISel]: Add GISelKnownBits analysis

Aditya Nandakumar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sun Aug 4 16:48:07 PDT 2019


aditya_nandakumar marked 9 inline comments as done.
aditya_nandakumar added inline comments.


================
Comment at: llvm/include/llvm/CodeGen/GlobalISel/GISelKnownBits.h:81
+protected:
+  virtual unsigned getMaxDepth() { return 6; }
+};
----------------
arsenm wrote:
> I would expect this to be a pass parameter, not a virtual function 
On second thought, does this need to be configurable at all? I don't see why users would need different depth's for different invocations. Maybe it's best to get rid of this configurability for now and re-add it when necessary.



================
Comment at: llvm/lib/CodeGen/GlobalISel/GISelKnownBits.cpp:28
+
+INITIALIZE_PASS_BEGIN(GISelKnownBitsPass, DEBUG_TYPE,
+                      "Analysis for ComputingKnownBits", false, true)
----------------
arsenm wrote:
> Remove Pass to fix PassPass
I renamed it to GISelKnownBitsAnalysis.


================
Comment at: llvm/lib/CodeGen/GlobalISel/GISelKnownBits.cpp:299
+  case TargetOpcode::G_PTRTOINT:
+    // Fall through and handle them the same as zext/trunc.
+    LLVM_FALLTHROUGH;
----------------
arsenm wrote:
> I thought these disallowed mismatched sizes
I'm not sure I completely follow. Could you please elaborate?


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D65698/new/

https://reviews.llvm.org/D65698





More information about the llvm-commits mailing list