[PATCH] D65205: [RISCV] Add Custom Parser for Atomic Memory Operands
Lewis Revill via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jul 31 03:09:47 PDT 2019
lewis-revill added inline comments.
================
Comment at: llvm/lib/Target/RISCV/AsmParser/RISCVAsmParser.cpp:1315
+ bool FoundInteger = false;
+ std::unique_ptr<RISCVOperand> RVOp;
+
----------------
Purely a style nitpick, but IMO this can be renamed as something like `OptionalImmOp`, then you can check for its existence instead of using the `FoundInteger` variable.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65205/new/
https://reviews.llvm.org/D65205
More information about the llvm-commits
mailing list