[PATCH] D65179: Changing representation of .cv_def_range directives in Codeview debug info assembly format for better readability
NILANJANA BASU via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jul 30 18:10:51 PDT 2019
nilanjana_basu marked 5 inline comments as done.
nilanjana_basu added inline comments.
================
Comment at: llvm/lib/MC/MCAsmStreamer.cpp:1423
+ OS << ", reg_rel, ";
+ OS << DRHdr.Register << ", " << DRHdr.Flags << ", "
+ << DRHdr.BasePointerOffset;
----------------
rnk wrote:
> Ideally, registers should be printed textually as rbp, ebp, etc. Given time constraints, I think we can leave that as a future improvement, though.
Will try to do this in the next patch before I leave.
================
Comment at: llvm/lib/MC/MCParser/AsmParser.cpp:3882
+ CVDefRangeType CVDRType = (CVTypeIt == CVDefRangeTypeMap.end())
+ ? CVDR_DEFRANGE
+ : CVTypeIt->getValue();
----------------
rnk wrote:
> I don't see a case for this enum... does it still work? I have to run to lunch, but I want to send these review comments now rather than later.
This is a placeholder enum, like DK_NO_DIRECTIVE in DirectiveKind. If the defrange type is not found, it is set to this value, & its executed in the default case. I have only implemented the 4 types that are implemented in CodeViewDebug.cpp.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65179/new/
https://reviews.llvm.org/D65179
More information about the llvm-commits
mailing list