[PATCH] D64577: [BitcodeReader] Use tighter upper bound to validate forward references.

JF Bastien via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 11 14:32:09 PDT 2019


jfb accepted this revision.
jfb added inline comments.
This revision is now accepted and ready to land.


================
Comment at: llvm/include/llvm/Bitstream/BitstreamReader.h:298
+  /// Return the size of stream.
+  size_t size() const { return BitcodeBytes.size(); }
+
----------------
I'd rather call this "sizeInBytes" or something. I get confused by bits and bytes :)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D64577/new/

https://reviews.llvm.org/D64577





More information about the llvm-commits mailing list