[PATCH] D64295: [X86][AMDGPU] Add an out parameter to isLoadBitCastBeneficial/isStoreBitCastBeneficial to indicate we shouldn't both checking the alignment.
Craig Topper via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Jul 7 15:46:17 PDT 2019
craig.topper marked an inline comment as done.
craig.topper added inline comments.
================
Comment at: llvm/include/llvm/CodeGen/TargetLowering.h:405
+ virtual bool isLoadBitCastBeneficial(EVT LoadVT, EVT BitcastVT,
+ bool &CheckAlignment) const {
+ CheckAlignment = true;
----------------
arsenm wrote:
> It isn't clear to me what this does the name, so needs a better name? Also needs a documentation comment for it
Do you have a better suggestion for a name? 'CallAllowsMemoryAccess'?
Or maybe I should just make isLoadBitCastBeneficial call the allowsMemoryAccess instead of DAGCombiner? Then X86 can control the behavior directly?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D64295/new/
https://reviews.llvm.org/D64295
More information about the llvm-commits
mailing list