[PATCH] D63447: [ARM] Put some of the TTI costmodel behind hasNeon calls.
Sjoerd Meijer via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jun 18 01:26:15 PDT 2019
SjoerdMeijer added a comment.
Hi Dave,
Bit of a wild idea/guess: I was wondering if you had given some thoughts if we could create some sort of abstraction for MVE and NEON. What I mean is that we're going to see a lot of
if (hasNEON())
// do this
if (hasMVE())
// do that
all over the place here. With long blocks and a lot of identation, readability is going to suffer a little bit. Is there something more c++y we could do here and provide different implementations whether we have NEON or MVE? Or would that not overly complicate things here, or not worth it?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D63447/new/
https://reviews.llvm.org/D63447
More information about the llvm-commits
mailing list