[PATCH] D63336: [CodeGen] Add RequiresLatch to HardwareLoopInfo

Dave Green via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Jun 15 01:16:02 PDT 2019


dmgreen added inline comments.


================
Comment at: lib/CodeGen/HardwareLoops.cpp:247
+        continue;
+      if (HWLoopInfo.RequiresLatch)
+        continue;
----------------
Maybe "RequiresLoopExitingLatch" as a more descriptive name?


================
Comment at: lib/Target/ARM/ARMTargetTransformInfo.cpp:706
   // For now, for simplicity, only support loops with one exit block.
   if (!L->getExitBlock())
     return false;
----------------
Is it worth just checking for the LoopExitingLatch here, as opposed to adding a parameter for it?

(Put another way, why would one be a parameter and the other be something for the backend to figure out?)


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D63336/new/

https://reviews.llvm.org/D63336





More information about the llvm-commits mailing list