[PATCH] D62976: [LLD] [COFF] Add an lld specific option /includeoptional

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 7 19:47:44 PDT 2019


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: COFF/Driver.cpp:1687-1690
+      Symbol *Sym = Symtab->find(Arg->getValue());
+      if (!Sym)
+        continue;
+      if (isa<Lazy>(Sym))
----------------
I think you can write them in one line

  if (auto *Sym = dyn_cast_or_null<Lazy>(Symtab->find(Arg->getValue()))


================
Comment at: COFF/Options.td:170
     "Do not demangle symbols in output">;
+def incl_optional : Joined<["/", "-", "/?", "-?"], "includeoptional:">,
+    HelpText<"Add symbol as undefined, but allow it to remain undefined">;
----------------
We use the same spellings for identifiers representing a symbol name, so I'd name this include_optional.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62976/new/

https://reviews.llvm.org/D62976





More information about the llvm-commits mailing list