[PATCH] D61599: [Support] Reverted r357058 and r351916, MemoryBlock class now exposes its allocated size instead of requested size.
Andrew Ng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu May 9 08:48:03 PDT 2019
andrewng added a comment.
Some of the changes in "lib/Support/Unix/Memory.inc" don't appear to have been clang formatted.
================
Comment at: lib/Support/FileOutputBuffer.cpp:78-79
public:
- InMemoryBuffer(StringRef Path, MemoryBlock Buf, unsigned Mode)
- : FileOutputBuffer(Path), Buffer(Buf), Mode(Mode) {}
+ InMemoryBuffer(StringRef Path, MemoryBlock Buf, std::size_t bufferSize, unsigned Mode)
+ : FileOutputBuffer(Path), Buffer(Buf), BufferSize(bufferSize), Mode(Mode) {}
----------------
Minor nit, perhaps bufferSize -> BufSize to match current naming convention?
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D61599/new/
https://reviews.llvm.org/D61599
More information about the llvm-commits
mailing list