[PATCH] D54409: PowerPC/SPE: Fix load/store handling for SPE

Justin Hibbits via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 29 07:26:39 PDT 2019


jhibbits marked 2 inline comments as done.
jhibbits added inline comments.


================
Comment at: lib/Target/PowerPC/PPCRegisterInfo.cpp:969
          "This should be handled in a target-independent way");
-  if (!noImmForm && ((isInt<16>(Offset) &&
+  bool canBeImmediate = (OpC == PPC::EVSTDD || OpC == PPC::EVLDD) ?
+                        isUInt<8>(Offset) :
----------------
nemanjai wrote:
> A more descriptive name might be something like `OffsetFitsMnemonic`. Notice the capitalization of the variable name as per coding guidelines.
Oops, I always forget about the capitalizations.  Sorry.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D54409/new/

https://reviews.llvm.org/D54409





More information about the llvm-commits mailing list