[PATCH] D58042: [LiveDebugValues] Emit parameter's entry value
Djordje Todorovic via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Apr 25 08:38:36 PDT 2019
djtodoro marked 5 inline comments as done.
djtodoro added inline comments.
================
Comment at: lib/CodeGen/LiveDebugValues.cpp:213
+ return Var < Other.Var;
+ if (Other.Kind == Kind)
return Loc.Hash < Other.Loc.Hash;
----------------
aprantl wrote:
> Now we're mixing both styles ;-)
>
> ```
> if (Var != Other.Var)
> return Var < Other.Var;
> if (Other.Kind != Kind)
> return Other.Kind < Kind;
> return Loc.Hash < Other.Loc.Hash;
> ```
Sorry. :)
================
Comment at: lib/CodeGen/LiveDebugValues.cpp:457
+
+ const MachineInstr *CurrDMI = &VarLocIDs[ID].MI;
+ auto DMI = std::find_if(ParamEntryVals.begin(), ParamEntryVals.end(),
----------------
aprantl wrote:
> I'm having trouble making sense of `DMI` (debug machine instruction?) is there a better name?
We can try.
================
Comment at: lib/CodeGen/LiveDebugValues.cpp:956
+ !MI.getDebugLoc()->getInlinedAt() && MI.getOperand(0).isReg() &&
+ MI.getOperand(0).getReg() && MI.getOperand(0).getReg() != SP) {
+ if (IsNewParameter(MI) && MI.getOperand(0).isReg())
----------------
aprantl wrote:
> Could this be a helper variable or function with a descriptive name that explains what this condition checks for?
Sure.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D58042/new/
https://reviews.llvm.org/D58042
More information about the llvm-commits
mailing list