[PATCH] D59959: [ConstantRange] Add unsigned and signed intersection type

Nikita Popov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Apr 6 08:18:08 PDT 2019


nikic added a comment.

I think I'd like to make two more changes here: Rename `IntersectionType` to `OperationType` or similar, as the Smallest/Unsigned/Signed classification will be useful in other places as well (e.g. it is also directly applicable to unions). Furthermore I'd like to change the enum class to an enum, as I don't think that `ConstantRange::OperationType::Smallest` adds anything over just `ConstantRange::Smallest`, beyond being unwieldy.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D59959/new/

https://reviews.llvm.org/D59959





More information about the llvm-commits mailing list