[PATCH] D60042: [llvm-objcopy] Add --prefix-alloc-sections
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Apr 4 04:45:48 PDT 2019
jhenderson accepted this revision.
jhenderson added a comment.
LGTM, but please wait for one of the other reviewers too.
================
Comment at: llvm/tools/llvm-objcopy/ELF/ELFObjcopy.cpp:630
+ // example, if we rename .text to .prefix.text, we also rename .rel.text
+ // to .rel.prefix.text.
+ } else if (isa<RelocationSectionBase>(&Sec)) {
----------------
Probably worth a comment saying that this doesn't apply to dynamic relocation sections and why.
================
Comment at: llvm/tools/llvm-objcopy/ObjcopyOpts.td:235
+defm prefix_alloc_sections
+ : Eq<"prefix-alloc-sections", "Add <prefix> to the start of every allocated section names">,
+ MetaVarName<"prefix">;
----------------
Nit: names -> name
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D60042/new/
https://reviews.llvm.org/D60042
More information about the llvm-commits
mailing list