[PATCH] D59982: [ELF] Rename SyntheticSection::empty to more appropriate needed() with opposite meaning

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 29 00:36:04 PDT 2019


MaskRay created this revision.
MaskRay added a reviewer: ruiu.
Herald added subscribers: llvm-commits, arichardson, emaste.
Herald added a reviewer: espindola.
Herald added a project: LLVM.

Some synthetic sections can be empty while still being needed, thus they
can't be removed by removeUnusedSyntheticSections(). Rename this member
function to more appropriate needed() with the opposite meaning.

No functionality change intended.


Repository:
  rLLD LLVM Linker

https://reviews.llvm.org/D59982

Files:
  ELF/SyntheticSections.cpp
  ELF/SyntheticSections.h
  ELF/Writer.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D59982.192783.patch
Type: text/x-patch
Size: 11912 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20190329/df9ef900/attachment-0001.bin>


More information about the llvm-commits mailing list