[PATCH] D59749: [ConstantRange] Fix isWrappedSet()
Roman Lebedev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Mar 26 14:43:52 PDT 2019
lebedev.ri added a comment.
In D59749#1443675 <https://reviews.llvm.org/D59749#1443675>, @lebedev.ri wrote:
> This is a bit too low-level and intrusive than i feel comfortable reviewing..
>
> It is best to split this up:
>
> 1. Rename `isWrappedSet()` into `isUpperWrapped()` (including all of it's uses). That would be an obvious, uncontroversial NFC commit.
> 2. Rename `isSignWrappedSet()` to something else like `isSignWrappedSetLegacy()`. NFC commit.
> 3. Introduce these 3 new functions. Also pretty much NFC.
> 4. The remaining of the patch
.. or, if `isSignWrappedSet()` change is NFC, then that can be [yet another] NFC commit after `Introduce these new functions` diff.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D59749/new/
https://reviews.llvm.org/D59749
More information about the llvm-commits
mailing list