[PATCH] D59716: [ConstantRange] Add full() + empty() named constructors (NFC)
Roman Lebedev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Mar 23 06:15:11 PDT 2019
lebedev.ri accepted this revision.
lebedev.ri added a comment.
This revision is now accepted and ready to land.
After looking into existing headers (esp. APInt) i think it will be best to name all of these `getFull()` and `getEmpty()`.
https://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly agrees:
`Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo()).`
Otherwise LG.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D59716/new/
https://reviews.llvm.org/D59716
More information about the llvm-commits
mailing list