[PATCH] D59216: [LLD][ELF][ARM] Redesign of .ARM.exidx handling to use a SyntheticSection
Peter Smith via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Mar 12 08:12:13 PDT 2019
peter.smith marked 6 inline comments as done.
peter.smith added a comment.
Thanks for the comments, I'll upload another diff with the changes.
================
Comment at: ELF/SyntheticSections.cpp:3188
+// We write the .ARM.exidx section contents then relocate. As the section
+// won't have been considered by scanRelocs() we must get the relocations
+// from the object file and process them manually. Luckily there is only
----------------
pcc wrote:
> Should the handling of `.ARM.exidx` input sections look more like `.eh_frame` sections, perhaps? You could:
> - remove `.ARM.exidx` sections from the `InputSections` list in `combineEhFrameSections` (and maybe rename the function) and add them to a separate list
> - arrange for `forEachRelSec` to visit those sections
> Now you should be able to write the sections in the usual way with `writeTo`.
Yes I think that is a better approach. I've updated the diff to do that.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D59216/new/
https://reviews.llvm.org/D59216
More information about the llvm-commits
mailing list