[PATCH] D58170: [DTU] Refine the interface and logic of applyUpdates
Chijun Sima via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 20 12:00:48 PST 2019
NutshellySima updated this revision to Diff 187644.
NutshellySima edited the summary of this revision.
NutshellySima added a comment.
1. Rename `applyUpdatesHinted` to `applyUpdatesPermissive`; Remove `applyUpdatesAccurate`.
2. Default to `strict` mode.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D58170/new/
https://reviews.llvm.org/D58170
Files:
llvm/include/llvm/Analysis/DomTreeUpdater.h
llvm/lib/Analysis/DomTreeUpdater.cpp
llvm/lib/Transforms/Scalar/CallSiteSplitting.cpp
llvm/lib/Transforms/Scalar/CorrelatedValuePropagation.cpp
llvm/lib/Transforms/Scalar/JumpThreading.cpp
llvm/lib/Transforms/Utils/BasicBlockUtils.cpp
llvm/lib/Transforms/Utils/Local.cpp
llvm/unittests/Analysis/DomTreeUpdaterTest.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D58170.187644.patch
Type: text/x-patch
Size: 27111 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20190220/979ba16f/attachment.bin>
More information about the llvm-commits
mailing list