[PATCH] D49366: [LLD][COFF] Add support for /FUNCTIONPADMIN command-line option

Reid Kleckner via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 20 11:31:46 PST 2019


rnk added a comment.

Neat!



================
Comment at: COFF/Driver.h:160
+// Parses a string in the form of "[:<integer>]"
+void parseFunctionpadmin(StringRef Arg, llvm::COFF::MachineTypes Machine);
+
----------------
Maybe parseFunctionPadMin to help readability? Initially I parsed it as "/function p admin", but I don't think that's right.


================
Comment at: test/COFF/functionpadmin.test:7
+RUN: lld-link %S/Inputs/precomp-a.obj /out:%t.exe /nodefaultlib /force /functionpadmin
+RUN: llvm-objdump -s %t.exe | FileCheck %s --check-prefix PADDED
+
----------------
Why objdump -s instead of objdump -d to look at the disassembly? Maybe the idea is that part of the test is to show that .rdata sections and .pdata sections are not padded with 0xCC? I guess that's good.


Repository:
  rLLD LLVM Linker

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D49366/new/

https://reviews.llvm.org/D49366





More information about the llvm-commits mailing list