[PATCH] D56969: GlobalISel: Fix widenScalarToNextPow2 mutation for vectors

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Feb 1 16:34:12 PST 2019


arsenm added a comment.

In D56969#1376445 <https://reviews.llvm.org/D56969#1376445>, @volkan wrote:

> In D56969#1376243 <https://reviews.llvm.org/D56969#1376243>, @arsenm wrote:
>
> > In D56969#1373222 <https://reviews.llvm.org/D56969#1373222>, @aemerson wrote:
> >
> > > My preference here would be to have a separate set of mutations for vector elements, @dsanders @aditya_nandakumar what do you think?
> >
> >
> > What about having 3 versions for each of these? e.g. minScalar, minElement, minScalarOrElement?
>
>
> I don't think we need separate mutations to do the same thing. I would prefer using widenScalarToNextPow2, but we should rename it to make it clear. Maybe something like widenScalarOrElementToNextPow2?
>
> @aemerson @arsenm, what do you think?


I still think having scalar and scalarOrElt versions of the various LegalizeRuleSet functions would be useful. I think there are legitimate uses for clamping the vector and scalar element sizes separately, and wanting both to match would also be common.  Also if I just change the behavior of all of these now, I'm going to have to update all of the targets with new, untested legalization behavior for all of the vector types. I'll try to produce the full set of these and see what it looks like.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D56969/new/

https://reviews.llvm.org/D56969





More information about the llvm-commits mailing list