[PATCH] D57365: [llvm-readobj] Add a flag to dump just the section-to-segment mapping.
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Feb 1 03:34:46 PST 2019
grimar added a comment.
I have only a 2 minor nits. Maybe @rupprecht has more to add.
================
Comment at: llvm/test/tools/llvm-readobj/gnu-phdrs.test:16
RUN: llvm-readobj -program-headers %p/Inputs/phdrs-elf.exe-x86_64 \
-RUN: --elf-output-style=GNU | FileCheck %s -check-prefix ELF64
+RUN: --elf-output-style=GNU | FileCheck %s -check-prefixes ELF64-PHDRS,ELF64-MAPPING
+RUN: llvm-readelf -program-headers %p/Inputs/phdrs-elf.exe-x86_64 \
----------------
nit: I suggest to follow the style of the previous line. I.e. place all arguments on the first line and FileCheck on the second.
(it is just a bit easier to read things when they are consistent):
```
RUN: llvm-readobj -program-headers %p/Inputs/phdrs-elf.exe-x86_64 --elf-output-style=GNU \
RUN: | FileCheck %s -check-prefixes ELF64-PHDRS,ELF64-MAPPING
```
================
Comment at: llvm/tools/llvm-readobj/ELFDumper.cpp:489
+ void printProgramHeaders(const ELFO *Obj);
+ void printSectionMapping(const ELFO *Obj) override {}
----------------
I would group `override` methods together.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D57365/new/
https://reviews.llvm.org/D57365
More information about the llvm-commits
mailing list