[PATCH] D57490: hwasan: Add __hwasan_init_static() function.

Evgenii Stepanov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 31 14:50:31 PST 2019


eugenis added inline comments.


================
Comment at: compiler-rt/include/sanitizer/hwasan_interface.h:26
+  // have been applied by the time the function is called. This also means that
+  // the function should be called before libc applies RELRO.
   // Does not call libc unless there is an error.
----------------
It should fine to call this function in dynamic executables if __rela_iplt symbols are declared weak.

In that case, would it be possible to get rid of __hwasan_init_static, and simply call __hwasan_init early enough? If not, is there a corresponding bionic patch to use__hwasan_init_static?



Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57490/new/

https://reviews.llvm.org/D57490





More information about the llvm-commits mailing list