[PATCH] D57128: Add --unwindlib=[libgcc|compiler-rt] to parallel --rtlib=

Kristina Brooks via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 28 21:06:43 PST 2019


kristina added a comment.

In D57128#1374928 <https://reviews.llvm.org/D57128#1374928>, @phosek wrote:

> One more thing, shouldn't libunwind be only included for C++ (since it's the internal dependency of libc++abi)? There shouldn't be any need to include it for C.


There's some dark magic done by glibc and thread cancellation, in absence of libgcc_s I think it may weakly link against symbols that would be provided by any unwinder library. I think it not being exposed **may** break glibc if using thread cancellation (not sure if that's used by a lot) without libgcc_s and without libc++abi loaded (to pull in the unwinder).

In D57128#1370712 <https://reviews.llvm.org/D57128#1370712>, @rsmith wrote:

> Looks good to me, thanks! Let's try this and see if it shakes out any problems.
>
> We really need to give LLVM's unwinder a better name.


I think most just call it `libunwind_llvm`?


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57128/new/

https://reviews.llvm.org/D57128





More information about the llvm-commits mailing list