[PATCH] D56873: [llvm-objcopy] [COFF] Implement --only-section
Jordan Rupprecht via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 18 13:51:37 PST 2019
rupprecht accepted this revision.
rupprecht added inline comments.
This revision is now accepted and ready to land.
================
Comment at: test/tools/llvm-objcopy/COFF/only-section.test:12
+
+SECTIONS: Sections:
+SECTIONS-NEXT: Idx Name
----------------
nit: these tests will be a little easier to read if they are indented something like this:
```
SECTIONS: xSections:
SECTIONS-NEXT: xIdx Name
SECTIONS-DEBUG-NEXT:x .debug_discardable
SECTIONS-TEXT-NEXT: x .text
SECTIONS-NEXT-EMPTY:x
```
(x's for clarity)
================
Comment at: test/tools/llvm-objcopy/COFF/only-section.test:21
+SYMBOLS-TEXT-NEXT: main
+SYMBOLS-EMPTY:
----------------
I'm not too familiar with using `-EMPTY` in filecheck, but is this supposed to be `SYMBOLS-NEXT-EMPTY`?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56873/new/
https://reviews.llvm.org/D56873
More information about the llvm-commits
mailing list