[PATCH] D54911: [compiler-rt][builtins][PowerPC] Add ___fixunstfti builtin compiler-rt method support for PowerPC

Robert Enenkel via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 9 08:18:05 PST 2019


renenkel added a comment.

If you haven't already, need to run Masoud's test program after making your changes.



================
Comment at: compiler-rt/test/builtins/Unit/ppc/fixunstfti_test.h:14
+};
+
+struct testCase testList[] = {
----------------
renenkel wrote:
> amyk wrote:
> > nemanjai wrote:
> > > It might be more readable to define a macro such as:
> > > `#define INIT_U128(HI, LO) (((__uint128_t) (HI) << 64) | (LO))`
> > > 
> > > And use that to initialize the 128-bit int values.
> > That is a good point; I agree with your suggestion. I will utilize a macro since it also enhances readability. 
> I agree.
Minor point - there are places in the conversion routine where INIT_U128 could also be used.  (Not essential to change this if you've already run Masoud's tests though.)


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D54911/new/

https://reviews.llvm.org/D54911





More information about the llvm-commits mailing list