[PATCH] D52694: [bindings/go] Add EraseFromParent

Ayke via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sun Jan 6 13:20:00 PST 2019


aykevl marked an inline comment as done.
aykevl added a comment.

Can someone merge this patch? I don't have commit access.



================
Comment at: bindings/go/llvm/ir.go:1213
 // Operations on instructions
+func (v Value) EraseFromParentAsInstruction()      { C.LLVMInstructionEraseFromParent(v.C) }
 func (v Value) InstructionParent() (bb BasicBlock) { bb.C = C.LLVMGetInstructionParent(v.C); return }
----------------
whitequark wrote:
> aykevl wrote:
> > aykevl wrote:
> > > whitequark wrote:
> > > > Nit: I'd call this `EraseInstructionFromParent`. (Also I'd deprecate `EraseFromParent` and rename it to `EraseBasicBlockFromParent`, but I'm not the Go bindings code owner so it's not my call.)
> > > Yes, that sounds better but I've kept it consistent with EraseFromParentAsFunction and EraseFromParentAsGlobal. Should it be changed, then?
> > ping?
> I'm not the Go bindings code owner so it seems better to go with the conservative naming.
Do you know who the owner is, then? @pcc? I can't find anyone closer in the CODE_OWNERS.TXT file.


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D52694/new/

https://reviews.llvm.org/D52694





More information about the llvm-commits mailing list