[PATCH] D56285: [MemorySSA] Add SkipSelfWalker.
George Burgess IV via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 4 09:32:15 PST 2019
george.burgess.iv added inline comments.
================
Comment at: include/llvm/Analysis/MemorySSA.h:890
std::unique_ptr<CachingWalker> Walker;
+ std::unique_ptr<SkipSelfWalker> TransformWalker;
unsigned NextID;
----------------
asbirlea wrote:
> george.burgess.iv wrote:
> > Nit: Why not call this `SkipSelfWalker`? (and `getSkipSelfWalker()`)?
> I agree with `getSkipSelfWalker()`, but the variable name will clash with the class name. Perhaps `SkipWalker` instead?
Good call; WFM
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56285/new/
https://reviews.llvm.org/D56285
More information about the llvm-commits
mailing list