[PATCH] D56285: [MemorySSA] Add SkipSelfWalker.

George Burgess IV via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 3 13:41:54 PST 2019


george.burgess.iv accepted this revision.
george.burgess.iv added a comment.
This revision is now accepted and ready to land.

LGTM modulo a naming nit. If you're happy with the suggestion, feel free to submit. Thanks!



================
Comment at: include/llvm/Analysis/MemorySSA.h:890
   std::unique_ptr<CachingWalker> Walker;
+  std::unique_ptr<SkipSelfWalker> TransformWalker;
   unsigned NextID;
----------------
Nit: Why not call this `SkipSelfWalker`? (and `getSkipSelfWalker()`)?


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D56285/new/

https://reviews.llvm.org/D56285





More information about the llvm-commits mailing list