[PATCH] D54875: [WebAssembly] Add support for the event section

Heejin Ahn via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 6 19:45:36 PST 2018


aheejin added inline comments.


================
Comment at: wasm/SymbolTable.cpp:153
+  const WasmSignature *OldSig = ExistingEvent->Signature;
+  if (NewType->Attribute != OldType->Attribute)
+    error("Event type mismatch: " + Existing->getName() + "\n>>> defined as " +
----------------
sbc100 wrote:
> This reminds me that `Attribute` is a really bad name, but we don't need to block landing this CL on that name which is LLVM side.
As I said in another CL, we can change it in the spec (and LLVM) if we want. Do you have any suggestions?


Repository:
  rLLD LLVM Linker

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D54875/new/

https://reviews.llvm.org/D54875





More information about the llvm-commits mailing list