[PATCH] D55220: [yaml2obj] Move redundant statements into a separate static function
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Dec 4 04:46:40 PST 2018
jhenderson added inline comments.
================
Comment at: tools/yaml2obj/yaml2elf.cpp:239
+
+static bool convertSymbolIndex(NameToIdxMap &SymN2I, StringRef SecName,
+ StringRef IndexSrc, unsigned &IndexDest) {
----------------
As this is only used the once, I don't think that it is useful to pull this case out into a separate function. I could be persuaded otherwise though.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55220/new/
https://reviews.llvm.org/D55220
More information about the llvm-commits
mailing list