[PATCH] D48348: [ADT] Add zip_longest iterators.

Michael Kruse via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Dec 3 14:37:53 PST 2018


Meinersbur updated this revision to Diff 176486.
Meinersbur marked an inline comment as done.
Meinersbur added a comment.

- Rebase
- Remove zip_longest_default, rename zip_longest_optional to zip_longest
- Use adl_begin/adl_end instead of std::begin/std::end
- Deconvolute zipped_and_filtered test


Repository:
  rL LLVM

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D48348/new/

https://reviews.llvm.org/D48348

Files:
  include/llvm/ADT/STLExtras.h
  unittests/ADT/IteratorTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D48348.176486.patch
Type: text/x-patch
Size: 8463 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20181203/4b230b06/attachment.bin>


More information about the llvm-commits mailing list