[PATCH] D54619: [ELF] - Refactor getRelocTargetVA(). NFC.
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Nov 16 00:53:32 PST 2018
grimar added inline comments.
================
Comment at: ELF/InputSection.cpp:786
+ if (Expr == R_HEXAGON_GOT)
+ return Sym.getGotVA() - In.GotPlt->getVA();
+ break;
----------------
Since this code does not use anything target specific, I think
`R_HEXAGON_GOT` should not have `HEXAGON` prefix and can be renamed
and moved to the common handlers group.
https://reviews.llvm.org/D54619
More information about the llvm-commits
mailing list