[PATCH] D54200: [PPC64] Use -0x80000000LL instead of std::numeric_limits<int32_t>::min()
Rui Ueyama via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Nov 7 05:40:58 PST 2018
ruiu added a comment.
My preference is INT32_MIN which works both in C and C++, but I don't think 0x80000000 is more readable than `numeric_limits<int32_t>::min()`. Honestly it looks a bit more like an exercise to see if you really understand how negative numbers are represented in the two's complement, I think.
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D54200
More information about the llvm-commits
mailing list