[PATCH] D52917: Avoid unnecessary buffer allocation and memcpy for compressed sections.

Rui Ueyama via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 4 17:41:40 PDT 2018


ruiu added inline comments.


================
Comment at: lld/test/ELF/relocatable-compressed-input.s:10
 
-## Check we decompress section and remove ".z" prefix specific for zlib-gnu compression.
+## Check we uncompress section and remove ".z" prefix specific for zlib-gnu compression.
 # CHECK:      Section {
----------------
MaskRay wrote:
> rLLD324944 did `s/uncompress/decompress/g`. If you now feel that `uncompress` is better, you may make these changes in a separate commit.
I understand the point but this is sort of related to this change because now I'm using `zlib::uncompress` instead of `Decompressor`. I think `Decompressor` should have been named `Uncompressor` in the first place, but I'm following the local convention (which is now "uncompress").


https://reviews.llvm.org/D52917





More information about the llvm-commits mailing list