[PATCH] D52081: [InstCombine] do not expand 8 byte memcpy if optimising for minsize
Sanjay Patel via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Sep 15 07:13:19 PDT 2018
spatel added a comment.
I agree with all of the earlier review comments:
1. The way the code is written currently is not good.
2. If we're going to expand at all, we should be using the datalayout to decide when that is appropriate (no magic numbers).
3. If we want to distinguish optimizing for size from optimizing for speed, that belongs in the backend - and it's already there. For example, see SelectionDAG::getMemcpy() and MemCpyOptimizer.cpp.
https://reviews.llvm.org/D52081
More information about the llvm-commits
mailing list