[llvm] r338398 - [DebugInfo] Fix build failed in 'clang-cmake-armv8-full'.

Hsiangkai Wang via llvm-commits llvm-commits at lists.llvm.org
Thu Aug 9 01:12:52 PDT 2018


On Wed, Aug 1, 2018 at 1:04 AM,  <paul.robinson at sony.com> wrote:
>
>
>> -----Original Message-----
>> From: llvm-commits [mailto:llvm-commits-bounces at lists.llvm.org] On Behalf
>> Of Hsiangkai Wang via llvm-commits
>> Sent: Tuesday, July 31, 2018 12:22 PM
>> To: llvm-commits at lists.llvm.org
>> Subject: [llvm] r338398 - [DebugInfo] Fix build failed in 'clang-cmake-
>> armv8-full'.
>>
>> Author: hsiangkai
>> Date: Tue Jul 31 09:22:09 2018
>> New Revision: 338398
>>
>> URL: http://llvm.org/viewvc/llvm-project?rev=338398&view=rev
>> Log:
>> [DebugInfo] Fix build failed in 'clang-cmake-armv8-full'.
>>
>> Builder clang-cmake-armv8-full failed due to the assembly 'comment'
>> notation is not '#' in the target. So, I use CHECK-SAME to avoid to
>> check the comment notation in the same line in the test case.
>>
>> Modified:
>>     llvm/trunk/test/DebugInfo/Generic/debug-label.ll
>>
>> Modified: llvm/trunk/test/DebugInfo/Generic/debug-label.ll
>> URL: http://llvm.org/viewvc/llvm-
>> project/llvm/trunk/test/DebugInfo/Generic/debug-
>> label.ll?rev=338398&r1=338397&r2=338398&view=diff
>> ==========================================================================
>> ====
>> --- llvm/trunk/test/DebugInfo/Generic/debug-label.ll (original)
>> +++ llvm/trunk/test/DebugInfo/Generic/debug-label.ll Tue Jul 31 09:22:09
>> 2018
>> @@ -21,15 +21,23 @@
>>  ; ASM: [[DONE_LABEL:[.0-9a-zA-Z]+]]:{{[[:space:]].*}}"done"
>>  ; ASM-LABEL: .debug_info
>>  ; ASM: DW_TAG_label
>> -; ASM-NEXT: [[TOP_LABEL]] # DW_AT_name
>> -; ASM-NEXT: 1 # DW_AT_decl_file
>> -; ASM-NEXT: 4 # DW_AT_decl_line
>> -; ASM-NEXT: [[TOP_LOW_PC]] # DW_AT_low_pc
>> +; ASM-NEXT: [[TOP_LABEL]]
>> +; ASM-SAME: DW_AT_name
>
> I am not saying you need to change anything, but another way to
> get this effect is with a wildcard regex.  So you could have said:
>
> ASM-NEXT: [[TOP_LABEL]] {{.*}} DW_AT_name
>
> It would mean the same thing, and be a little bit more readable IMO.
> Something to remember for another test, another day.
> --paulr

Got it. Thanks for your advice.
>
>> +; ASM-NEXT: 1
>> +; ASM-SAME: DW_AT_decl_file
>> +; ASM-NEXT: 4
>> +; ASM-SAME: DW_AT_decl_line
>> +; ASM-NEXT: [[TOP_LOW_PC]]
>> +; ASM-SAME: DW_AT_low_pc
>>  ; ASM: DW_TAG_label
>> -; ASM-NEXT: [[DONE_LABEL]] # DW_AT_name
>> -; ASM-NEXT: 1 # DW_AT_decl_file
>> -; ASM-NEXT: 7 # DW_AT_decl_line
>> -; ASM-NEXT: [[DONE_LOW_PC]] # DW_AT_low_pc
>> +; ASM-NEXT: [[DONE_LABEL]]
>> +; ASM-SAME: DW_AT_name
>> +; ASM-NEXT: 1
>> +; ASM-SAME: DW_AT_decl_file
>> +; ASM-NEXT: 7
>> +; ASM-SAME: DW_AT_decl_line
>> +; ASM-NEXT: [[DONE_LOW_PC]]
>> +; ASM-SAME: DW_AT_low_pc
>>
>>  source_filename = "debug-label.c"
>>
>>
>>
>> _______________________________________________
>> llvm-commits mailing list
>> llvm-commits at lists.llvm.org
>> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-commits


More information about the llvm-commits mailing list