[PATCH] D49499: [X86] Prefer unpckhpd over movhlps in isel for fake unary cases

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jul 31 10:46:45 PDT 2018


RKSimon added inline comments.


================
Comment at: lib/Target/X86/X86InstrSSE.td:831
                       Sched<[SchedWriteFShuffle.XMM]>;
   let isCommutable = 1 in
   def MOVHLPSrr : PSI<0x12, MRMSrcReg, (outs VR128:$dst),
----------------
craig.topper wrote:
> RKSimon wrote:
> > Shouldn't it only be commutable if it has SSE2? Looking at X86InstrInfo::commuteInstructionImpl it asserts that SSE2 is available, it doesn't early out....
> It's checked in findCommutedOpIndices which should be called before commuteInstructionImpl.
Cheers - I wrote that code and had completely forgotten....


https://reviews.llvm.org/D49499





More information about the llvm-commits mailing list