[PATCH] D49676: [DWARF] support for .debug_addr (consumer)

Victor Leschuk via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jul 31 08:03:26 PDT 2018


vleschuk marked 4 inline comments as done.
vleschuk added inline comments.


================
Comment at: lib/DebugInfo/DWARF/DWARFDebugAddr.cpp:155
+  static const char *Fmt64 = "0x%16.16" PRIx64;
+  std::string AddrFmt = "\n";
+  std::string AddrFmtVerbose = " => ";
----------------
JDevlieghere wrote:
> I think a `raw_string_ostream` might better communicate your intentions of building up a string. 
I don't think so, in this situation usage of additional ostreams to build a format string will result in more code which will be less readable. I'd prefer to keep current code.


https://reviews.llvm.org/D49676





More information about the llvm-commits mailing list