[PATCH] D48857: Also search BitcodeFiles for exclude-lib symbols
Rui Ueyama via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jul 5 12:00:33 PDT 2018
ruiu added inline comments.
================
Comment at: ELF/Driver.cpp:1156
- for (InputFile *File : ObjectFiles)
+ auto markSymbolsInFile = [&](InputFile *File) {
if (!File->ArchiveName.empty())
----------------
We don't need to give a long descriptive name for a local variable whose scope is narrow. Also, in LLVM/lld, local variables must be in CamelCase. I'd name this just `Visit`.
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D48857
More information about the llvm-commits
mailing list