[PATCH] D48569: [AMDGPU] Convert rcp to rcp_iflag
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jun 26 00:35:27 PDT 2018
arsenm added inline comments.
================
Comment at: lib/Target/AMDGPU/SIISelLowering.cpp:6644
+
+ return AMDGPUTargetLowering::PerformDAGCombine(N, DCI);
+}
----------------
rampitec wrote:
> arsenm wrote:
> > This can just return SDValue(). The base PerformDAGCombine isn't going to do anything here
> In fact not, there is combining code in parent and having no this call results in tests regression.
Oh, I see there is constant folding there already.
It would probably be better then to either factor that into a function which can be called from here, or to just handle all of this is one performRcpCombine
https://reviews.llvm.org/D48569
More information about the llvm-commits
mailing list