[PATCH] D48026: [ScopHelper] Provide support for recognising collective invariant loads

SAHIL GIRISH YERAWAR via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 22 07:48:38 PDT 2018


cs15btech11044 marked 4 inline comments as done.
cs15btech11044 added inline comments.


================
Comment at: lib/Support/ScopHelper.cpp:446
+                            ScalarEvolution &SE, const DominatorTree &DT,
+                            InvariantLoadsSetTy &RequiredILS) {
   Loop *L = LI.getLoopFor(LInst->getParent());
----------------
philip.pfaffe wrote:
> RequiredILS should be `const&`.
> 
> More bikeshed: Why 'Required'? I'd consider 'KnownInvariantLoads' to be more apt, what do you think?
I agree. It sounds apter here.


https://reviews.llvm.org/D48026





More information about the llvm-commits mailing list