[PATCH] D48349: [ADT] Add llvm::unique_function which is like std::function but supporting move-only closures.
Chandler Carruth via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 21 00:46:54 PDT 2018
chandlerc added a comment.
In https://reviews.llvm.org/D48349#1138090, @zturner wrote:
> In that case maybe `FunctionExtras.h` in keeping with the llvm naming
> spirit
I'm fine with the idea of this, but I'm always frustrated by the generic "extras" name component. Feels about as useless at "Utils". But I lack a significantly better idea....
Closest thing to a better idea I have is `FunctionTypeErasure.h` or `CallableTypeErasuer.h`. Thoughts? Other folks with naming thoughts here?
Repository:
rL LLVM
https://reviews.llvm.org/D48349
More information about the llvm-commits
mailing list