[PATCH] D48172: [CostModel][AArch64] Add some initial costs for SK_Select and SK_PermuteSingleSrc

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 19 11:15:22 PDT 2018


RKSimon added inline comments.


================
Comment at: lib/Target/AArch64/AArch64TargetTransformInfo.cpp:964
+    static const CostTblEntry SelectTbl[] = {
+        {ISD::VECTOR_SHUFFLE, MVT::v2i32, 1},
+        {ISD::VECTOR_SHUFFLE, MVT::v4i32, 2},
----------------
evandro wrote:
> Independently of the costs, this lookup table could be simplified to a test on the number of vector elements.
That's trivial to do - the tables look easier to grok, but I'm happy to make the change.


Repository:
  rL LLVM

https://reviews.llvm.org/D48172





More information about the llvm-commits mailing list