[PATCH] D48199: [scudo] Add verbose failures in place of CHECK(0)
Filipe Cabecinhas via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jun 15 03:30:53 PDT 2018
filcab added inline comments.
================
Comment at: lib/scudo/scudo_allocator.cpp:328
// it can, every 100ms, otherwise it will just return the current one.
- bool isRssLimitExceeded() {
+ NOINLINE bool isRssLimitExceeded() {
u64 LastCheck = atomic_load_relaxed(&RssLastCheckedAtNS);
----------------
Maybe also define it out of line? No use making the class definition harder to read if we don't even want to inline this function.
Repository:
rCRT Compiler Runtime
https://reviews.llvm.org/D48199
More information about the llvm-commits
mailing list