[PATCH] D47989: [llvm-readobj] Add -string-dump (-p) option
Eric Christopher via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jun 12 10:34:09 PDT 2018
echristo added a reviewer: dblaikie.
echristo added a comment.
One inline nit and adding Dave here.
Dave: I put a note in the review here - as someone who wasn't originally a C programmer any ideas on how to do this more idiomatically? ;)
================
Comment at: tools/llvm-readobj/ELFDumper.cpp:152
void printProgramHeaders() override;
+ void dumpSectionAsString(StringRef StringName) override;
void printHashTable() override;
----------------
Nit: Could we match the naming convention of the rest of the code?
================
Comment at: tools/llvm-readobj/ELFDumper.cpp:3226
+ StringRef SectionName) {
+ char *StrPtr;
+ long SectionIndex = strtol(SectionName.data(), &StrPtr, 10);
----------------
Dave: Here.
Repository:
rL LLVM
https://reviews.llvm.org/D47989
More information about the llvm-commits
mailing list