[PATCH] D46365: AMDGPU: Separate R600 and GCN TableGen files

Tom Stellard via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 31 11:55:45 PDT 2018


tstellar marked 8 inline comments as done.
tstellar added inline comments.


================
Comment at: lib/Target/AMDGPU/AMDGPUSubtarget.h:207-208
+
+class AMDGPUSubtarget : public AMDGPUGenSubtargetInfo,
+                        public AMDGPUCommonSubtarget {
 public:
----------------
arsenm wrote:
> Why isn't this SISubtarget/GCNSubtarget?
I was planning to rename this as a follow on patch to avoid creating even more churn in this patch. 


================
Comment at: lib/Target/AMDGPU/AMDGPUSubtarget.h:436-438
+  virtual bool hasAddr64() const {
+    return (getGeneration() < AMDGPUSubtarget::VOLCANIC_ISLANDS);
   }
----------------
arsenm wrote:
> Why is this needed outside of GCN code?
It's not.  I've dropped the R600 implementation of this.


Repository:
  rL LLVM

https://reviews.llvm.org/D46365





More information about the llvm-commits mailing list