[PATCH] D46200: Mitigate relocation overflow [part 2 of 2]
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu May 17 11:16:28 PDT 2018
grimar added inline comments.
================
Comment at: ELF/Writer.cpp:1709
+ // section.
+ OutputSection *DefaultOutSec = findSection(".text");
+ if (!DefaultOutSec)
----------------
ruiu wrote:
> Since this function is very small, we probably should use shorter names. I'd name this just `Text`.
But `Text` does not look correct for `Out::ElfHeader` case. Maybe `OutSec`?
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D46200
More information about the llvm-commits
mailing list