[PATCH] D46567: [llvm-strip] Add support for -remove-section

Alexander Shaposhnikov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 10 21:57:57 PDT 2018


alexshap marked an inline comment as done.
alexshap added inline comments.


================
Comment at: test/tools/llvm-objcopy/strip-and-remove.test:1
+# RUN: yaml2obj %s > %t
+# RUN: cp %t %t1
----------------
jhenderson wrote:
> What are your thoughts on renaming this test to strip-all-and-remove.test? That way it's clear that we are testing the combination of the two switches of llvm-objcopy, one of which is effectively always on for llvm-strip. It also allows for easier distinguishing from strip-debug.
yeah, sounds good to me, will rename this test to strip-all-and-remove.test


================
Comment at: test/tools/llvm-objcopy/strip-and-remove.test:17
+Sections:
+  - Name:            .debugfoo
+    Type:            SHT_PROGBITS
----------------
jhenderson wrote:
> If this is intended to be a real debug section, it probably is worth naming it in the same style as other debug sections i.e. .debug_foo.
ok, will rename it to .debug_foo


Repository:
  rL LLVM

https://reviews.llvm.org/D46567





More information about the llvm-commits mailing list