[PATCH] D45559: [WebAssembly] Add Wasm personality and usesWindowsEHInstructions()
David Majnemer via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 9 15:37:59 PDT 2018
majnemer added a comment.
In https://reviews.llvm.org/D45559#1093526, @aheejin wrote:
> As I said above, the term 'funclet' seems to be used pretty everywhere including clang. To summarize its usage,
>
> 1. Small outlined functions themselves
> 2. Funcletpad instructions, such as `catchpad` or `cleanuppad`
> 3. The structure of BBs starting from `catchpad`/`cleanuppad` and ending with `catchret`/`cleanupret`, which can be nested
> 4. This Windows IR -based EH itself
>
> Now I'm thinking that maybe we should use `isFuncletEHPersonality` for the use cases here I replaced with `usesWindowsEHInstructions`, and come up with a new name to give to the use cases that pertain to real outlined small functions.
I think that is probably the most prudent. Really, "funclet" should be renamed to "scope" everywhere but the AsmPrinter, sorry about that...
Repository:
rL LLVM
https://reviews.llvm.org/D45559
More information about the llvm-commits
mailing list