[PATCH] D45788: Mitigate relocation overflow [part 1 of 2]
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue May 1 14:00:43 PDT 2018
grimar added a comment.
This change looks good for me (with a better name for rank).
Currently, as you know, there are 57 failing test cases.
Please fix them and update the patch.
================
Comment at: ELF/Writer.cpp:689
+ RF_NOT_TLS = 1 << 10,
+ RF_DYN_SYM = 1 << 9,
RF_BSS = 1 << 8,
----------------
`RF_DYN_SYM` does not seem to be a good name because
you use it for both SHT_DYNSYM and SHT_STRTAB.
I do not have an idea about the good name now. Maybe `RF_ALLOC_FIRST`?
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D45788
More information about the llvm-commits
mailing list